Mac System Requirements

To use your product and its software, your Mac should use one of these operating systems:

Note: The UNIX File System (UFS) and Fast User Switching is not supported.
Note: For the latest product software available for your operating system, visit the Epson support site at epson.com/support (U.S.), epson.ca/support (Canada), or epson.com.jm/support (Caribbean), select your product, and select Downloads.